It is currently Thu Mar 23, 2017 3:16 am
   
Text Size

Komplete Pitch Issue

Macintosh software/hardware discussion and troubleshooting

Moderator: James Steele

Komplete Pitch Issue

Postby Movies » Fri Feb 03, 2017 7:04 pm

I'm using Komplete as a plug-in with DP 9.02. Absolutely nothing has changed about my set-up for months.

For some reason, in the past couple days, seemingly random Kontakt instruments will just change pitch. Like, the MIDI data is correct, but Kontakt starts transposing the pitches. It's not project-specific (I tried four or five different files). It's just one instrument at a time.

Does anyone have any thoughts on what might be doing this?
MacBook Pro 2.5 GHz Quad-Core Intel i7/16GB, OSX 10.11.5, DP 9.02, MOTU 896mk3
Movies
 
Posts: 289
Joined: Thu Dec 04, 2008 1:14 pm
Location: Boston, MA
Primary DAW OS: MacOS

Re: Komplete Pitch Issue

Postby HCMarkus » Fri Feb 03, 2017 11:05 pm

Possible suspect: Pitch bend CC... Is DP set to chase pitch bend events?
User avatar
HCMarkus
 
Posts: 5794
Joined: Tue Jan 10, 2006 10:01 am
Location: Rancho Bohemia, California
Primary DAW OS: MacOS

Re: Komplete Pitch Issue

Postby Movies » Sat Feb 04, 2017 5:15 am

Everything is checked in the Even Chasing window, so yes.

But, also, unless there's some key command that would've enabled it by accident, I definitely haven't gone in there for anything.
MacBook Pro 2.5 GHz Quad-Core Intel i7/16GB, OSX 10.11.5, DP 9.02, MOTU 896mk3
Movies
 
Posts: 289
Joined: Thu Dec 04, 2008 1:14 pm
Location: Boston, MA
Primary DAW OS: MacOS

Re: Komplete Pitch Issue

Postby Movies » Fri Mar 17, 2017 6:38 am

It turns out that this issue is not only happening in Kontakt. It's happening in pretty much any plug-in -- even MAS plug-ins.

More interestingly, when it happens, if I just save everything exactly how it is, close DP and reopen the project, it's back to normal.

Totally weird.
MacBook Pro 2.5 GHz Quad-Core Intel i7/16GB, OSX 10.11.5, DP 9.02, MOTU 896mk3
Movies
 
Posts: 289
Joined: Thu Dec 04, 2008 1:14 pm
Location: Boston, MA
Primary DAW OS: MacOS

Re: Komplete Pitch Issue

Postby mikehalloran » Fri Mar 17, 2017 8:31 am

What does MOTU support say?
July 2010 iMac 2.93G i7 Quad, OWC eSATA mod, 32G RAM, OS 10.12.3
828mkII FW; MOTU MTP/AV USB with Firmware 2.0.1; DP 9.21, 9.02, 8.07 64bit, DP 7.24; IK-NI-Izotope-PSP-Garritan Antares, 32Lives, JBridge, MachFive 3.2.1
LogicPro X 10.3, Finale 25.2, 2014.5, Encore 5.0.7, Overture 5.2, TwistedWave, DSP-Quatro 4.4, QuickTime Pro 7.6.6, SmartScore Pro X2 10.5.5, Toast 15
Test machine: G4-1K Dual Processor: OS 10.4.11 / OS 9.2.2; DP 5.13; Encore 5.05 & 4.5.5; Toast 9.07b, legacy apps
User avatar
mikehalloran
 
Posts: 7926
Joined: Sun Jan 25, 2009 6:08 pm
Location: Sillie Con Valley
Primary DAW OS: MacOS

Re: Komplete Pitch Issue

Postby HCMarkus » Fri Mar 17, 2017 9:11 am

Is it possible you opened a Transpose window with "preview" checked that is now hidden behind other windows?
User avatar
HCMarkus
 
Posts: 5794
Joined: Tue Jan 10, 2006 10:01 am
Location: Rancho Bohemia, California
Primary DAW OS: MacOS

Komplete Pitch Issue

Postby Sean Kenny » Fri Mar 17, 2017 6:08 pm

Movies wrote:It turns out that this issue is not only happening in Kontakt. It's happening in pretty much any plug-in -- even MAS plug-ins.

More interestingly, when it happens, if I just save everything exactly how it is, close DP and reopen the project, it's back to normal.

Totally weird.

I have experienced this too, fortunately I don't use MIDI that much these but it's a real pain


Sent from my iPad using Tapatalk
Mac Pro 3 GHz 8-Core Intel Xeon E5 - 32 GB Ram 1867 MHz DDR3 ECC - OS X 10.9.5 - DP 9.1 - RME HDSPe Madi card - iz ADA converters 24 i/o - Audient desk - M&K Monitors - very understanding wife!
http://www.ten21recordingstudios.co.uk/
User avatar
Sean Kenny
 
Posts: 177
Joined: Fri May 26, 2006 12:40 am
Location: Kent - England
Primary DAW OS: Unspecified

Re: Komplete Pitch Issue

Postby terrybritton » Sat Mar 18, 2017 8:15 am

HCMarkus wrote:Possible suspect: Pitch bend CC... Is DP set to chase pitch bend events?


I second this. I have an Alesis QX49 I don't use much anymore because it sends out spurious and random pitch bend messages. Watch your controllers with a MIDI monitor, or screen out pitch bend and see if the issue goes away.

Terry
Computer: Dell XPS 8700-1751BLK | Intel Haswell Core i7 4790@3.6Mhz | 16GB DDR3 1600Mhz | Windows 10 Pro x64 |
MOTU 828 mk3 hybrid- USB

DAWs and Live: MOTU Digital Performer 9.1.2 | Samplitude Pro X3 Suite | Cantabile 3 Performer
Keyboard Synths: Kawai K5000s, Korg Wavestation, Korg Poly800
Controllers: NI Komplete Kontrol S-88, Akai MPK249, Alesis QX49; NI Maschine Jam; Peavey PC 1600x
Rack Modules: Ensoniq ESQm, Yamaha TX81Z, Lexicon LXP-5

Videos: http://www.youtube.com/tbritton33
User avatar
terrybritton
 
Posts: 458
Joined: Thu Jun 04, 2015 8:45 am
Location: Elizabeth City, NC
Primary DAW OS: Windows

Re: Komplete Pitch Issue

Postby Movies » Sun Mar 19, 2017 1:46 pm

I chatted to MOTU about it and they had two suggestions:

1. My controller could be sending out random weird pitch data, however:

A. The controller that's hooked up (an Akai LPK25) doesn't send pitch data

B. Even if it did, I can't imagine that it would uniformly alter already-programmed MIDI information.

2. Though there's a very, very slim chance, trashing my preferences might solve the problem:

This seems pretty super unlikely -- even the MOTU tech representative was skeptical.
MacBook Pro 2.5 GHz Quad-Core Intel i7/16GB, OSX 10.11.5, DP 9.02, MOTU 896mk3
Movies
 
Posts: 289
Joined: Thu Dec 04, 2008 1:14 pm
Location: Boston, MA
Primary DAW OS: MacOS

Re: Komplete Pitch Issue

Postby terrybritton » Sun Mar 19, 2017 1:51 pm

Movies wrote:I chatted to MOTU about it and they had two suggestions:

1. My controller could be sending out random weird pitch data, however:

A. The controller that's hooked up (an Akai LPK25) doesn't send pitch data

B. Even if it did, I can't imagine that it would uniformly alter already-programmed MIDI information.

2. Though there's a very, very slim chance, trashing my preferences might solve the problem:

This seems pretty super unlikely -- even the MOTU tech representative was skeptical.


Well, if the Akai LPK25 you have hooked up sends no pitch data, that pretty much sews up that suspicion!

At this point, I usually consider that it has to be ghosts -- poltergeists to be exact. Software written by common humans could not be this malicious!

Terry
Computer: Dell XPS 8700-1751BLK | Intel Haswell Core i7 4790@3.6Mhz | 16GB DDR3 1600Mhz | Windows 10 Pro x64 |
MOTU 828 mk3 hybrid- USB

DAWs and Live: MOTU Digital Performer 9.1.2 | Samplitude Pro X3 Suite | Cantabile 3 Performer
Keyboard Synths: Kawai K5000s, Korg Wavestation, Korg Poly800
Controllers: NI Komplete Kontrol S-88, Akai MPK249, Alesis QX49; NI Maschine Jam; Peavey PC 1600x
Rack Modules: Ensoniq ESQm, Yamaha TX81Z, Lexicon LXP-5

Videos: http://www.youtube.com/tbritton33
User avatar
terrybritton
 
Posts: 458
Joined: Thu Jun 04, 2015 8:45 am
Location: Elizabeth City, NC
Primary DAW OS: Windows

Re: Komplete Pitch Issue

Postby cuttime » Sun Mar 19, 2017 5:56 pm

I'm confused. How does a keyboard controller not send pitch data? Time to beak out the trusty Snoize MIDI monitor and see what's really happening:

https://www.snoize.com/MIDIMonitor/
Traveler DP9.12 Unisyn 10.6.8 and 10.12.3 i7 iMac 16G
User avatar
cuttime
 
Posts: 2747
Joined: Sun May 15, 2005 10:01 pm
Primary DAW OS: MacOS

Re: Komplete Pitch Issue

Postby MIDI Life Crisis » Sun Mar 19, 2017 8:21 pm

A) How much is it transposing by?

B) Could there be a discrepancy between sample rates?

C) What is you sample rate in DP?

D) What is the sample rate on your audio device/card?

E) Have you tried changing the sample rates in DP and your audio device/card?

F) Does Komplete have a sample rate option?
2013 Mac Pro 32GB RAM

OSX 10.12.3; DP 9.1; Track 16 F'n 25 (brain dead Finale)

http://www.MIDILifeCrisis.com
User avatar
MIDI Life Crisis
 
Posts: 23592
Joined: Wed May 18, 2005 10:01 pm
Primary DAW OS: MacOS


Return to General Macintosh

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 151 on Tue Jan 28, 2014 1:07 pm

Users browsing this forum: No registered users and 1 guest

Login Form