It is currently Sun Mar 26, 2017 12:19 am
   
Text Size

UNofficial Digital Performer Community issue list - Windows

For seeking technical help with Digital Performer and/or plug-ins on Windows.

Moderators: James Steele, Shooshie

Forum rules
This forum is for seeking solutions to technical problems involving Digital Performer and/or plug-ins on Windows, as well as feature requests, criticisms, comparison to other DAWs.

UNofficial Digital Performer Community issue list - Windows

Postby Robert Randolph » Mon Jun 13, 2016 7:18 am

This thread exists to maintain a public, community maintained list of issues in the current version of Digital Performer.

This is for bugs that are specific to Windows. It is assumed that OS X is the 'default' OS for DP unless otherwise indicated.

What constitutes an issue for the purposes of this thread

  • 1.) Crashing DP
  • 2.) Crashing other software when executing a function in DP
  • 3.) Behaviour contrary to documentation
  • 4.) Undocumented changes that do not work contrary to expectation or marketing.
  • 5.) Inconsistent display of information
  • 6.) Display glitches
  • 7.) Inconsistencies with repeated identical input
  • 8.) Undocumented changes from previous versions
  • 9.) Any behaviour that has been accepted as 'buggy' by motu. Requires proof of a techlink response.
  • 10.) Well documented performance decrease from a previous version of DP

What is not an issue

  • Performance differences unless reproducible across a wide range of systems
  • Desire for DP to behave differently than documented
  • Issues that can't be reproduced by at least 2 people
  • Reports from non-current versions (unless corroborated to be present in a current version)
  • Issues with hardware unless they are completely unique to DP
  • Manual Errata
  • Any issues with third-party plugins that can be reproduced in at least 2 other DAWs.
  • Anything that primarily compares DP's behaviour to another DAW
  • Behaviour that only manifests in the presence of uncommon system configuration.


To file an issue:


Not using the template will cause extra work for me. The better information you can provide, the better we can log your issue and potentially provide workarounds in the meantime!

Discussion should occur in this thread: viewtopic.php?f=1&t=61940

Please only post concise reports of issues in this thread. Thank you!
Last edited by Robert Randolph on Mon Oct 10, 2016 11:41 am, edited 5 times in total.
DP9.02 3.5ghz i5 late 2013 iMac. 2011 17" i7 Macbook Pro. OS X 10.12.3. Way too many plug-ins.
User avatar
Robert Randolph
 
Posts: 856
Joined: Tue Apr 29, 2014 6:50 am
Location: St. Petersburg, Florida
Primary DAW OS: MacOS

Re: UNofficial Digital Performer Community bug list - Window

Postby Robert Randolph » Mon Jun 13, 2016 7:18 am

See FAQ listed here: viewtopic.php?f=1&t=61937#p527094

I reported this issue and it's not listed yet, what's going on

I will lag behind slightly on checking Windows only issues, since I do not use Windows as my primary OS. I ask the community to help extra with confirming these issues.

If you feel that I've been too slow, just shoot me a PM or email audiolabs [at] gmail.com
Last edited by Robert Randolph on Wed Jun 15, 2016 7:33 pm, edited 2 times in total.
DP9.02 3.5ghz i5 late 2013 iMac. 2011 17" i7 Macbook Pro. OS X 10.12.3. Way too many plug-ins.
User avatar
Robert Randolph
 
Posts: 856
Joined: Tue Apr 29, 2014 6:50 am
Location: St. Petersburg, Florida
Primary DAW OS: MacOS

Re: UNofficial Digital Performer Community bug list - Window

Postby Robert Randolph » Mon Jun 13, 2016 7:20 am

Confirmed issues

Statuses:
[Verification In Progress]
[Confirmed]
[Accepted by Motu]
[Fixed in Version X.X]

List of issues at a glance

Title: Values not showing for older stock plugins (for instance, Trim)
Reference: #0000001

Status: [Accepted by Motu]

Original Reports:
  • none


Title: Custom59 can freeze DP's gui
Reference: #0000002

Status: [Accepted by Motu]

Original Reports:
  • none
Last edited by Robert Randolph on Thu Jul 28, 2016 11:27 am, edited 7 times in total.
DP9.02 3.5ghz i5 late 2013 iMac. 2011 17" i7 Macbook Pro. OS X 10.12.3. Way too many plug-ins.
User avatar
Robert Randolph
 
Posts: 856
Joined: Tue Apr 29, 2014 6:50 am
Location: St. Petersburg, Florida
Primary DAW OS: MacOS

Re: UNofficial Digital Performer Community bug list - Window

Postby Robert Randolph » Mon Jun 13, 2016 7:21 am

Rejected issues

List of issues at a glance
  • Reference # - 'Title'

Title: Brief issue description
Reference: #0000000

Status: [Rejected]

Original Reports:

Reason for rejection:
There's a fly in my soup.
Last edited by Robert Randolph on Mon Jun 13, 2016 9:56 am, edited 6 times in total.
DP9.02 3.5ghz i5 late 2013 iMac. 2011 17" i7 Macbook Pro. OS X 10.12.3. Way too many plug-ins.
User avatar
Robert Randolph
 
Posts: 856
Joined: Tue Apr 29, 2014 6:50 am
Location: St. Petersburg, Florida
Primary DAW OS: MacOS

Re: UNofficial Digital Performer Community bug list - Window

Postby Robert Randolph » Mon Jun 13, 2016 7:23 am

Reserved.
DP9.02 3.5ghz i5 late 2013 iMac. 2011 17" i7 Macbook Pro. OS X 10.12.3. Way too many plug-ins.
User avatar
Robert Randolph
 
Posts: 856
Joined: Tue Apr 29, 2014 6:50 am
Location: St. Petersburg, Florida
Primary DAW OS: MacOS

Re: UNofficial Digital Performer Community issue list - Wind

Postby kelldammit » Thu Jul 28, 2016 10:53 am

win10, DP 9.1(x64)
Issue 1: values not showing for older stock plugins (for instance, Trim). Value fields are just white. You can enter values, and they seem to take effect...you just can't see what the values actually are. Some of the newer plugins also exhibit minor gui misalignments (megasynth is one).
Reported/confirmed to MOTU, as of v8. It seems related to win10 specifically from what i can tell.

Issue 2: Custom59 can freeze DP's gui (unless you press/hold a fader or similar, at which point animations, like the transport counter will work until the button or fader is released).
Save/restart of DP seems to cure it, but it can be re-triggered afterward. It seems to have to do with modifying the tubes, pre amp, power amp and speaker cab settings. Usually changing a few will cause the issue. LiveRoomG does similar (add a mic, modify stuff, and the gui freezes similarly to custom59). In both cases, audio passes just fine.
Both reported/confirmed by MOTU. This has been present since v8, and doesn't seem to correlate to any OS in particular (win7, 8.1, and 10 all exhibit this issue for me).
This freezing seems to be along the lines of when you run with too much cpu in use, DP will "freeze" the gui animations to allow audio to pass. So it's probably triggered by a cpu spike, but DP doesn't realize that it's not a continuous state (at least the meter doesn't show more than a spike). That's my guess anyway.
Feed the children! Preferably to starving wild animals.
ASUS 2.5ghz i7 laptop, 32Gb RAM, win8.1 x64, RME Babyface, Akai MPK-61, Some Plugins, Guitars and Stuff, Lava Lamps.
User avatar
kelldammit
 
Posts: 1009
Joined: Sun May 22, 2005 10:01 pm
Location: right behind you!
Primary DAW OS: Windows


Return to Digital Performer [Windows]: Troubleshooting/Criticism

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 151 on Tue Jan 28, 2014 1:07 pm

Users browsing this forum: No registered users and 1 guest

Login Form