It is currently Wed May 24, 2017 11:54 pm
   
Text Size

MIDI playback issues

For seeking technical help with Digital Performer and/or plug-ins on Windows.

Moderators: James Steele, Shooshie

Forum rules
This forum is for seeking solutions to technical problems involving Digital Performer and/or plug-ins on Windows, as well as feature requests, criticisms, comparison to other DAWs.

MIDI playback issues

Postby mopho007 » Tue May 10, 2016 6:58 pm

I've been a long time DP Mac user (ever since 1987, back when it was just Performer) and have never really had any issues with DP. I recently decided to give the Windows version a try since there are several Windows only synth editors I need to use.

I'm having some serious MIDI playback issues. I have demo versions of DP9 on a iMac running 64-bit Win 7 (quad core 2.7 i5, 32-GB ram, 1TB) and HP also running 64-bit Win 7 (quad 2.4 intel Q6600, 3-GB ram, 600GB). Both have the same MIDI playback problem (less on the iMac). Problem is both machines can't seem to playback even a simple repeating 16 quarter notes on a single MIDI track (no other tracks on the project) without dropping notes randomly and/or making notes hang/freeze. It's even worse when I engage Transmit MIDI Sync to my drum machine. I can open my older DP7 audio only session from DP 7.2 Mac and those work fine. Seems odd that two machines would not be able to handle extremely basic MIDI playback? :banghead:

Could this be a MIDI driver issue? I have a MTP AV (usb version) and 828MkIII audio interface. Try re-installing the latest MOTU drivers for both but no luck in fixing the issue. :shake:

Thanks
mopho007
 
Posts: 5
Joined: Tue May 10, 2016 6:22 pm
Primary DAW OS: Windows

Re: MIDI playback issues

Postby stubbsonic » Wed May 11, 2016 7:43 am

There was an issue in DP7 where if you had quantized notes of the same pitch where you quantized the note starts and ends, then DP would play a short note if it was the second of two-- the releases would interfere with subsequent notes.

EDIT: They fixed this in DP8. I just went and tested to confirm.

You can certainly try this fix by selecting some notes and reducing their durations so that the end of the earlier notes is not right up against the start of the later notes.

I had resolved this by adding a plugin on each MIDI tracks to subtract 1 tick from all durations.

See if that sorts it. I can't imagine they'd have let this bug back in with DP9, but perhaps it is in some specific context.
RMBP (2.6 i7), FF800, OS 10.10.5, DP8, Kontakt, Reaktor, K2661S, K2500RS, iPad4, (also an old sawtooth G4 with a UAD-1 for legacy apps).

http://www.jonstubbsmusic.com
User avatar
stubbsonic
 
Posts: 2256
Joined: Fri Dec 22, 2006 1:56 pm
Primary DAW OS: MacOS

Re: MIDI playback issues

Postby mopho007 » Wed May 11, 2016 9:11 am

I've tried everything, changing the note duration time or start does not fix the issue. I even opened a MIDI only project from the Mac (DP7.2) and DP9 on Windows can't play it back - random notes drop and freezing sustained notes.

I took the test files I created on Windows DP9, and then put them in the Mac (DP7.2) and the Mac plays them back 100% correctly. So it must be a USB MIDI driver issue for some sort?

Was hoping someone else had ran into the problem and knew the fix. :boohoo:
mopho007
 
Posts: 5
Joined: Tue May 10, 2016 6:22 pm
Primary DAW OS: Windows


Return to Digital Performer [Windows]: Troubleshooting/Criticism

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 151 on Tue Jan 28, 2014 1:07 pm

Users browsing this forum: No registered users and 1 guest

Login Form