It is currently Thu Mar 23, 2017 3:24 am
   
Text Size

Performance problems w/ DP 8, Win 10

For seeking technical help with Digital Performer and/or plug-ins on Windows.

Moderators: James Steele, Shooshie

Forum rules
This forum is for seeking solutions to technical problems involving Digital Performer and/or plug-ins on Windows, as well as feature requests, criticisms, comparison to other DAWs.

Performance problems w/ DP 8, Win 10

Postby 0cme » Tue May 03, 2016 9:22 pm

Hello all, so recently I've been having performance problems in DP 8 when playing a very reasonable number of virtual instruments. This problem cropped up a few weeks ago, persisted for a few days, went away, came back for a few days, and vanished again this afternoon. I'm skeptical about how long this will last though so I'm hoping I can fix this for good somehow.

I haven't installed anything, software wise, since the problem arose. I did add more RAM to the PC after the problem first arose, but that doesn't seem to have helped.

The problem manifests itself as performance slowing down when the music gets very dense and a lot of virtual instruments are playing, to the point where the processing bar in DP is red, the interface is slow to respond, audible stutters, gaps, and then finally the warning dialog about performance pops up. During this time, the Windows Task Manager shows DP using 50% of the CPU. It's a 4-core CPU, so it seems to be maxing out 2 cores. When the problem isn't happening, the same place in the music will play back flawlessly, with the processing bar bouncing around around in the low green, and the Windows Task Manager showing DP using 30-40% of the CPU.

(I'm not sure how much I trust the Windows 10 Task Manager though.)

The problem can come and go without warning... it was stuttering like mad when I opened it earlier today, and when I came back this evening, it's working fine. I didn't even *restart* the computer during that time, just re-opened DP.

There are 3 virtual instruments: two instances of Kontakt 5 with about 20 instruments loaded between them, and one instance of EW Play, with just a few instruments loaded. There are no other plugins in use.

I've tried all kinds of things:

-Compacting the project, saving, re-saving, going back to versions saved before the problem arose, trashing preferences folder
-Turning on and off record for any or all tracks, trying to put the virtual instruments into and out of 'interactive' mode
-Using Windows Audio or ASIO as the hardware driver
-Turning off my MIDI keyboard
-Optimizing hard drives
-Adding RAM to the system

...nothing seems to help, it just comes and goes as it pleases. Has anyone experienced anything like this? Any ideas, before I nuke C: and re-install Windows? Thanks!

DP 8.07
Windows 10 Pro v. 1511, 64-bit (upgraded from Win 7)
Core i7 920 (2.67 ghz)
12 gb RAM
ssd system/application drive
separate ssd sample drive
EMU XMIDI 1x1 usb interface
0cme
 
Posts: 3
Joined: Sat Sep 13, 2014 7:07 pm
Primary DAW OS: Windows

Re: Performance problems w/ DP 8, Win 10

Postby mikehalloran » Wed May 04, 2016 1:02 pm

Do not "optimize" an SSD—ever. Let TRIM do its job. It's built into the OS.
viewtopic.php?f=2&t=61654&hilit=Optimize+SSD

One up from the bottom of the page.

Sometimes you have to run a debug or low level monitor tool to see exactly what's going on. The last time I did tech support for Windows, XP was new so I am no longer current on the best tools to find the problem.
July 2010 iMac 2.93G i7 Quad, OWC eSATA mod, 32G RAM, OS 10.12.3
828mkII FW; MOTU MTP/AV USB with Firmware 2.0.1; DP 9.21, 9.02, 8.07 64bit, DP 7.24; IK-NI-Izotope-PSP-Garritan Antares, 32Lives, JBridge, MachFive 3.2.1
LogicPro X 10.3, Finale 25.2, 2014.5, Encore 5.0.7, Overture 5.2, TwistedWave, DSP-Quatro 4.4, QuickTime Pro 7.6.6, SmartScore Pro X2 10.5.5, Toast 15
Test machine: G4-1K Dual Processor: OS 10.4.11 / OS 9.2.2; DP 5.13; Encore 5.05 & 4.5.5; Toast 9.07b, legacy apps
User avatar
mikehalloran
 
Posts: 7926
Joined: Sun Jan 25, 2009 6:08 pm
Location: Sillie Con Valley
Primary DAW OS: MacOS

Re: Performance problems w/ DP 8, Win 10

Postby 0cme » Wed May 04, 2016 2:30 pm

Thanks Mike. The "Optimize Drives" tool in Windows 10 automatically picks the right method (defragmentation vs. trim) for the particular drive (HD vs. SSD). That's the tool I used.
0cme
 
Posts: 3
Joined: Sat Sep 13, 2014 7:07 pm
Primary DAW OS: Windows

Re: Performance problems w/ DP 8, Win 10

Postby mesayre » Fri Jun 03, 2016 3:36 pm

Any chance your system is indexing files for later search? That'll do it.
DP 8.07 - Win 10 - Intel i7 8-core w/ 16GB Ram
mesayre
 
Posts: 76
Joined: Sun Aug 18, 2013 7:04 am
Location: New York, NY
Primary DAW OS: Windows

Re: Performance problems w/ DP 8, Win 10

Postby Mathematics » Thu Aug 25, 2016 3:03 am

First off...I see you successfully have an EMU product functioning with DP8; lucky you. I had no such luck with an EMU PCIe interace and went all MOTU thereafter. Now for your weird latency and CPU overloading - My potential solution is not a cheap one but I briefly had an issue like that when I first started using DP but it all went away after using Vienna Ensemble Pro to host all the instruments. To be honest, when I load a project and if I see the CPU load bar bouncing, I just move my instruments (and even my plugin signal chain) into VEPro and let that processing occur externally; that is, outside the DAW. This way, DP is only handling MIDI. The added latency is near zero when the Vienna Server Host and VEP instance are on the same computer. Don't worry if that sounds scary and technical...it's not. I feel like a salesperson for VSL.

Results? Well, the best resulting change I ever got this instrument hosting management was going from a near 90% cpu load down to about 20%. That's not always the case but I can tell you this much, it's a world of difference on average.

Why does this work? I'm not the developer so what I notice in either DP8, DP9...whichever one doesn't matter, the internal processing and core management is actually pretty good but some plugin combination cause spikes, especially Waves because they don't claim 100% compatibility, as of now, with Windows-based DP. For instance, Waves Aphex, Saphira, REDD, and J37 hit the CPU hard. Running them anywhere together in the same project almost always give me a spike but I just run them all outside the DAW in a VEP instance and it all goes away. Additionally, you can also run those plugins and instruments in another computer and route the audio out of DP and let a second computer handle the audio plugin processing. This way, your computer is actually doing nothing but playing audio. The computer you have is more than capable of running this.

All this sounds great but does come with a price tag and required hardware lock just to demo the software. I can't imagine not having VEPro.

Now, for the next-to-free alternative. Image your current W10 installation with Marium Reflect Free edition and go back to Windows 7. Without losing your current OS installation, get any kind of HD and swap out your current boot drive so as not to disturb your current configuration (the image is your second backup for super safety...you should do this anyway) and install W7 and everything else on it and try running your project again. If you like the way it works, use Macrium Reflect Free again, to clone that W7 installation to another SSD drive of your choice or onto the W10 drive if you don't want to spend more money. Yes, this means overwriting the current W10 installation but at least you still have a backup image of it. This is a going to take a lot of time to do but, if you're serious about this...it would be worth the effort.

Also...realize that W10 is constantly harvesting information about you and learning how you use the computer. So, it makes sense that one moment it's running smooth and then next it's not. Some people have great experiences with W10 and others don't. Personally, I only run W7 systems for audio and video and use and IcyDock swap bay to switch between W7 and W10 on one computer which I use for everthing else that is not audio or video.

Please disregard misspells and grammatical errors.
PC, Win7, DP 9.12, i7/Xeon multi-system gigabit network, Live 9 Suite, Pro Tools, M4L, Melodyne, Waves, Wave Arts, Native Instruments, Xfer, Spectralayers 3, Vienna, EastWest, Izotope, Mackie, Yamaha, AVID, Adobe, MOTU 2408mk3, ART, Rode, Tascam, Sennheiser, dbx, Korg, Akai
Mathematics
 
Posts: 67
Joined: Wed May 27, 2015 4:18 am
Location: Los Angeles, CA
Primary DAW OS: Windows


Return to Digital Performer [Windows]: Troubleshooting/Criticism

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 151 on Tue Jan 28, 2014 1:07 pm

Users browsing this forum: No registered users and 1 guest

Login Form