It is currently Tue Oct 21, 2014 11:26 pm
   
Text Size

TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Discussion of Digital Performer use, optimization, tips and techniques on MacOS.

Moderators: James Steele, Shooshie

Forum rules
This forum is for most discussion related to the use and optimization of Digital Performer [MacOS] and plug-ins as well as tips and techniques. It is NOT for troubleshooting technical issues, complaints, feature requests, or "Comparative DAW 101."

Postby nk_e » Sun Aug 24, 2008 4:06 am

Thanks James. This really very helpful.

12 core MacPro 2.66GHZ | 14 GB RAM | OS 10.9 | DP 8.0.5 | CUBASE 7.5 | MOTU Interfaces | Way Too Many Plug-ins |

http://www.gesslr.com
http://soundcloud.com/gesslr
FB: gesslr.gesslr
@gesslr via Twitter

Check out the DP 8 Tutorials at Groove 3!
http://www.groove3.com/str/Digital-Perf ... ained.html
http://www.groove3.com/str/Digital-Perf ... anced.html
User avatar
nk_e
 
Posts: 551
Joined: Wed Jul 04, 2007 5:04 am
Location: USA
Primary DAW OS: MacOS

Postby tommymandel » Sun Aug 24, 2008 6:03 am

I'm going to try it with my Novation Remote SL25. They make a DP Template (though I'm sure it's not v.6-savvy, if that makes a difference...) but their DP Template doesn't activate the Transport buttons either. Perhaps this unit will also respond favorably to the same Most Excellent James Fix.
DP 8.07 8core3Ghz 16GB/10.6.8, two 24i/o's, Digi 002R, PhonicHelixFW18, MicroExpressUSB--- MBP 2011 16GB/10.6.8, ReMOTE SL---DP 8.07 SupDrmr, Mainstage, jBridgeM, SampleTron, OB-SEM V, Miroslav, ScarbeeEEP, PPG.v3, Jupiter-8v2, WAVESTATION, Martinic Combo V, Fab4, Pro53; Nomad, Soundtoys, AdrenaLinnIII box +Plug-In,NI GuitarRig, Tempest - PT8Hardware rig at http://www.tommymandel.com/famous.html/tmrig.html"
User avatar
tommymandel
 
Posts: 963
Joined: Tue Nov 30, 2004 11:01 pm
Location: New York
Primary DAW OS: MacOS

Postby Tobor » Sun Aug 24, 2008 12:56 pm

James Steele wrote:
Tobor wrote:I programmed everything in enough to realize the stop/play etc. was actually working. But hitting FF led to a runaway train and DP freeze.


That's odd. I need to look into this, because it works fine on mine... however... it only fast forwards as I'm holding down the FF button on my Oxygen 49. Soon as I let up on it the FF stops.


Hi James,

It's quite possible that the crash happened because I had a lot of programs open on the MB and could have just hit a few successive keystrokes too quickly. I'll tackle it again today.

Great workaround suggestions from Tonio and MLC about IAC driver, low note entry (imagine all hell would break loose if you assigned everything to C-2 and then actually hit it!), and about going back into 5.X to change things.

At least I'm learning a lot about Commands and their import/export etc., by this exercise!

Thanks again to all,

Tobor
iMac 2.7 i5, DP 8.07/7.24, 10.9.4, 828, MTPAV, Toontrack, Spectrasonics, BFD3, Drumcore, Reason 6.5, Live 9, Logic X, Miroslav, Waves, Kronos X, MOXF 6, Axiom 49.
User avatar
Tobor
 
Posts: 648
Joined: Mon Jan 31, 2005 11:01 pm
Location: Colorado
Primary DAW OS: MacOS

Postby Tobor » Sun Aug 24, 2008 4:37 pm

O.K., I'm 80% there.....

I was able to delete the old MIDI commands in DP5 and import the key bindings to DP6. I set up the new commands via James' tutorial and Enigma programming.

The memory loop command toggles on and off. Check. The record button toggles on and off. Check. The play command plays. Check.

But here's my glitch. The 'stop' button stops DP. BUT....I notice that the stop button on DP's transport bar remains depressed, and I can't press another button (like 'play' again) and have it work. When I hit the depressed 'stop' button manually with mouse on the transport bar order is restored.

Likewise, when I hit rewind, DP rewinds to the beginning of the sequence (great) but the rewind button on the transport bar remains depressed until toggled off manually with the mouse.

And when I hit the FF button it continues fast forwarding and cannot be stopped by any means, causing a defacto crash and I have to force quit DP.

So, it's a head scratcher. With the same programming, three of the Axiom transport buttons work great and three don't.

???????? So close.....

Tobor
iMac 2.7 i5, DP 8.07/7.24, 10.9.4, 828, MTPAV, Toontrack, Spectrasonics, BFD3, Drumcore, Reason 6.5, Live 9, Logic X, Miroslav, Waves, Kronos X, MOXF 6, Axiom 49.
User avatar
Tobor
 
Posts: 648
Joined: Mon Jan 31, 2005 11:01 pm
Location: Colorado
Primary DAW OS: MacOS

Postby MIDI Life Crisis » Mon Aug 25, 2008 12:48 pm

Just got this techlink answer from MOTU:

We are aware of an issue in Digital Performer 6.0 that prevents a MIDI note on event from being unassigned from a command in the Commands window. We expect to address this issue with a future update to Digital Performer.
_______________________________________________________________________
_______________________________________________________________________
_____________________________MIDI Life Crisis______________________________
_______________________________________________________________________
_____________OS 10.9.4 • DP 64 bit • 8 core MP/20GB RAM • Track 16____________
User avatar
MIDI Life Crisis
 
Posts: 20452
Joined: Wed May 18, 2005 10:01 pm
Primary DAW OS: MacOS

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby Tobor » Tue Aug 26, 2008 10:10 pm

Thanks MLC for the update.

Thought I'd bump this, since with the new 'look and feel' of the board being somewhat of a distraction, more Axiom/Oxygen users would certainly find James' tutorial useful.

And I'd still like some help on why, with the same programming, the 'Play', 'Loop', and 'Record' buttons all work correctly for me, yet the FF, Rewind, and Stop buttons 'stick' on DP (see above post for complete details), making complete remote operation impossible for now.

Tobor
iMac 2.7 i5, DP 8.07/7.24, 10.9.4, 828, MTPAV, Toontrack, Spectrasonics, BFD3, Drumcore, Reason 6.5, Live 9, Logic X, Miroslav, Waves, Kronos X, MOXF 6, Axiom 49.
User avatar
Tobor
 
Posts: 648
Joined: Mon Jan 31, 2005 11:01 pm
Location: Colorado
Primary DAW OS: MacOS

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby James Steele » Wed Aug 27, 2008 12:19 am

Tobor wrote:Thanks MLC for the update.

Thought I'd bump this, since with the new 'look and feel' of the board being somewhat of a distraction, more Axiom/Oxygen users would certainly find James' tutorial useful.

And I'd still like some help on why, with the same programming, the 'Play', 'Loop', and 'Record' buttons all work correctly for me, yet the FF, Rewind, and Stop buttons 'stick' on DP (see above post for complete details), making complete remote operation impossible for now.

Tobor


I'm at a loss on that one Tobor. Did you make certain when you programmed the keyboard that the changes took? Try manually bumping down a preset then back up, then click on the button with Enigma to make certain the correct values are there. Also make sure that when assigning the button in the Commands Window of DP, you highlight the MIDI Message column, push and HOLD DOWN the button, then click somwhere outside the value entry box with the mouse before releasing the button so that the controller value stored is 127 and not 0.
User avatar
James Steele
Site Administrator
 
Posts: 15084
Joined: Fri Oct 15, 2004 10:01 pm
Location: San Diego, CA - U.S.A.
Primary DAW OS: MacOS

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby Resonant Alien » Wed Aug 27, 2008 5:48 am

James - could you make this a sticky for easy finding later?

Thanks,
Rick
...
Resonant Alien
 
Posts: 1374
Joined: Wed Nov 10, 2004 11:01 pm
Primary DAW OS: Unspecified

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby Tobor » Wed Aug 27, 2008 11:10 am

James Steele wrote:
Tobor wrote:
And I'd still like some help on why, with the same programming, the 'Play', 'Loop', and 'Record' buttons all work correctly for me, yet the FF, Rewind, and Stop buttons 'stick' on DP (see above post for complete details), making complete remote operation impossible for now.

Tobor


I'm at a loss on that one Tobor. Did you make certain when you programmed the keyboard that the changes took? Try manually bumping down a preset then back up, then click on the button with Enigma to make certain the correct values are there. Also make sure that when assigning the button in the Commands Window of DP, you highlight the MIDI Message column, push and HOLD DOWN the button, then click somwhere outside the value entry box with the mouse before releasing the button so that the controller value stored is 127 and not 0.



Thanks, James. I just went through everything again. The programming matches your model exactly. I had wondered about 'value 2' in Enigma, as it defaults to 127 when you type in 146 in the top box, where your example has 'value 2' at 0. But no difference.

It's just odd that with the same programming three buttons work and three don't. Another interesting clue re: the three buttons that don't work. When the corresponding button is pressed (Stop, for example), the 'Stop' button on DPs transport bar remains depressed, that is, highlighted. As I mentioned before this can be toggled off on the stop and rewind buttons with a mouse, but there's no stopping the FF once it gets going.

I may have to try the dreaded tech support hotline numbers later today. I'd so like to get this working since it's so close.

Thanks again for all your help.

Tobor
iMac 2.7 i5, DP 8.07/7.24, 10.9.4, 828, MTPAV, Toontrack, Spectrasonics, BFD3, Drumcore, Reason 6.5, Live 9, Logic X, Miroslav, Waves, Kronos X, MOXF 6, Axiom 49.
User avatar
Tobor
 
Posts: 648
Joined: Mon Jan 31, 2005 11:01 pm
Location: Colorado
Primary DAW OS: MacOS

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby Tonio » Wed Aug 27, 2008 1:52 pm

Tabor,
I had that problem too initially. I figured that the loop button was making DP go into memory mode.

What preset did you make changes in Enigma? Memory or default?

I copied the default and made a user preset into preset 1- GM MIDI(you have to download it from the default), then I made the necessary changes for each button. I did have to go back and 0 out zome of the entries I missed.
Uploaded that to the Axiom. Then I loaded the user preset on the Axiom as prest 1 GM MIDI by hitting recall, numeric 1.

Actually I had to do this twice, sine I made mistakes on a few itms.

T
MP 2.66 1,1 /OS10.6.8 /DP7.12/MOTU1224-PCIe424/Lavry DA-10/
User avatar
Tonio
 
Posts: 1225
Joined: Sun Oct 17, 2004 10:01 pm
Location: San Diego
Primary DAW OS: Unspecified

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby Tobor » Wed Aug 27, 2008 3:21 pm

Tonio wrote:Tabor,
I had that problem too initially. I figured that the loop button was making DP go into memory mode.

What preset did you make changes in Enigma? Memory or default?

I copied the default and made a user preset into preset 1- GM MIDI(you have to download it from the default), then I made the necessary changes for each button. I did have to go back and 0 out zome of the entries I missed.
Uploaded that to the Axiom. Then I loaded the user preset on the Axiom as prest 1 GM MIDI by hitting recall, numeric 1.

Actually I had to do this twice, sine I made mistakes on a few itms.

T


Hi Tonio,

Yes, I also copied the preset bank into a user preset bank and started working on that bank's GM MIDI patch one as well. The loop button does toggle the memory on and off, but that button works fine and wouldn't explain the 'fast forward into infinity' freakout.

I actually just got off the phone with M-Audio support. Great help and patience on and off for the last couple hours. Thanks! We did a lot of troubleshooting and experimenting with the Axiom and Enigma using Reason, which is what he had available. I was able to recreate the FF snafu on Reason when I programmed it with the CC 146 patch. The Reason transport preset (7) uses MIDI notes, and the tech seemed to think that DP might work better with a similar MIDI learn procedure. Obviously James and others have been able to use the above tutorial CC method with great success, so I might just try redoing everything by that method again as well as the MIDI note path.

There was just enough funkiness getting the Enigma banks to load and presets to 'stick' to make me think that by starting from scratch and repeating the procedure a couple times, I might get lucky eventually. I certainly learned a lot of useful info in the process, and thanks again to P at M-Audio for all the insight and effort.

Thanks, Tonio, for the 'try, try again' encouragement. I'll report back when and if I hit paydirt.

Tobor
iMac 2.7 i5, DP 8.07/7.24, 10.9.4, 828, MTPAV, Toontrack, Spectrasonics, BFD3, Drumcore, Reason 6.5, Live 9, Logic X, Miroslav, Waves, Kronos X, MOXF 6, Axiom 49.
User avatar
Tobor
 
Posts: 648
Joined: Mon Jan 31, 2005 11:01 pm
Location: Colorado
Primary DAW OS: MacOS

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby Tobor » Wed Aug 27, 2008 3:53 pm

Paydirt!

In the grand tradition of 'just turn it off, just turn it on', I did a factory reset on the Axiom, re-uploaded the user bank with all the tutorial data, booted Digital Performer and rolled up my sleeves to give it another go. Loaded the 'tutorial' preset, thought I'd just hit all the buttons one more time, and as if by magic, everything now works!!

Thanks to all !!

Tobor
iMac 2.7 i5, DP 8.07/7.24, 10.9.4, 828, MTPAV, Toontrack, Spectrasonics, BFD3, Drumcore, Reason 6.5, Live 9, Logic X, Miroslav, Waves, Kronos X, MOXF 6, Axiom 49.
User avatar
Tobor
 
Posts: 648
Joined: Mon Jan 31, 2005 11:01 pm
Location: Colorado
Primary DAW OS: MacOS

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby RecordingArts » Sat Sep 13, 2008 11:04 pm

Thanks James. This is going to be a HUGE help. When it's set up right, the Axiom has the potential to cover a lot of bases in a very compact, affordable package. Once again, You Rock :) †Vincent
DP8.01, MacBookPro 2.3Ghz i7, MacOS 10.8.3, 512Gig OCZ Vertex 4 SSD, 750 Gig Momentus XT Drive in the optical slot :-) BFD2, Trilian, Ivory2, MSI, MX-4, Philharmonik, Komplete, Reason 4, Live 6, Melodyne, IKMulti's Total Studio, ARC, T-RackS 3, SampleTron, AMG's KickA--Brass. Pettinhouse Guitar and Bass, a Mic and some Guitars :)
User avatar
RecordingArts
 
Posts: 1903
Joined: Fri Feb 03, 2006 8:50 pm
Location: Southern California
Primary DAW OS: Unspecified

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby dosuna11 » Sun Sep 14, 2008 10:56 am

Has anyone had any luck in 4.61? I followed the directions and can see all the correct info in the Dp dialog boxes the Axiom and DP aren't dating yet.
iMac 2.7Ghz quadcore i5 16 gig RAM DP 7.24 OS 10.6.8, iMac G5 2.1GHz 2.5 gig Ram DP 5.13 OS 10.4.11 MOTU 828 MK2, East West Platinum Plus, Miroslav Philharmonic, Komplete 5, Kontakt 2 Garritan Big Band, Mr Sax T, The Trumpet, DrumCore, Trilogy and Trillian, Ivory, MachFive, Ethno Instrument, Reason 4, SampleTank 2 Sampletron, Samplemoog, Melodyne Editor, Nomad plugins, Vintage Warmer, Ozone 4, Amplitube Jimi, Xgear and AmpegSVX.
http:www.davidosuna.com
http://www.myspace.com/davidosuna
dosuna11
 
Posts: 1107
Joined: Sat May 21, 2005 10:01 pm
Location: Mountlake Terrace, Washington
Primary DAW OS: MacOS

Re: TUTORIAL: M-Audio Axiom/Oxygen Transport Controls with DP

Postby James Steele » Sun Sep 14, 2008 11:24 am

dosuna11 wrote:Has anyone had any luck in 4.61? I followed the directions and can see all the correct info in the Dp dialog boxes the Axiom and DP aren't dating yet.


You turned the Main Transport Remote on, or whatever right? (sorry, not in front of DP). Did you create the instrument in AMS like in my second post?

I don't have 4.61 any more so can't test this myself.
JamesSteele.com | Dean Guitars | Facebook | Google+ | Twitter

MacPro4,1 Quad-Core 2.66, 24GB RAM, OS 10.9.4, ATI 5770, DP 8.07, MOTU HD192, 24I/O, UAD-2 Duo, Lucid GENx192, HV-3C, Red Type B, Dean guitars, Marshall amps, etc., etc.!
User avatar
James Steele
Site Administrator
 
Posts: 15084
Joined: Fri Oct 15, 2004 10:01 pm
Location: San Diego, CA - U.S.A.
Primary DAW OS: MacOS

PreviousNext

Return to Digital Performer [MacOS]: Usage, Techniques, Tips & Optimization

Who is online

Users browsing this forum: No registered users and 4 guests


Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 151 on Tue Jan 28, 2014 1:07 pm

Users browsing this forum: No registered users and 4 guests

Login Form