It is currently Fri Jan 19, 2018 12:50 am
   
Text Size

High Sierra, DP and UAD Pluggins

For seeking technical help with Digital Performer and/or plug-ins on MacOS.

Moderators: James Steele, Shooshie

Forum rules
This forum is for seeking solutions to technical problems involving Digital Performer and/or plug-ins on MacOS, as well as feature requests, criticisms, comparison to other DAWs.

Re: High Sierra, DP and UAD Pluggins

Postby Gravity Jim » Fri Jan 12, 2018 1:44 pm

Just want to point out that nobody should delay updating either DP or OSX if you worry that your UAD plugs won't work.

Because mine still work, with no futzing around.

The only thing the latest update broke was my HAL 9000 Screensaver.
Jim Bordner
http://www.gravitymusic.com
MacPro 5,1 (3.33Ghz 12-core), 32g RAM, OS X 10.13.3 Beta • MOTU 896mk3 • MOTU DP 9.5.1 • Logic Pro X 10.2.5 • Waves Diamond, UAD-2, Slate Digital, Komplete, Omnisphere 2, LASS, CineSamples, Chipsounds, V Collection 5, Korg Legacy • Roland & Yamaha hardware • Fender, Gibson, Godin, Danelectro, Line 6, Warmoth, Hofner and Cedar Creek guitars, Fuchs ODS amp
User avatar
Gravity Jim
 
Posts: 1830
Joined: Wed Apr 30, 2008 2:55 am
Location: Santa Rosa, CA
Primary DAW OS: MacOS

Re: High Sierra, DP and UAD Pluggins

Postby Babz » Fri Jan 12, 2018 5:14 pm

Gravity Jim wrote:Just want to point out that nobody should delay updating either DP or OSX if you worry that your UAD plugs won't work.

Because mine still work, with no futzing around.

The only thing the latest update broke was my HAL 9000 Screensaver.


I just spoke to MOTU on the phone today and they confirmed that the there is currently still an unresolved issue with the latest UAD and DP under High Sierra.

What kind of UAD are you using? Is it Firewre? The original poster on this uses Firewire. Maybe that is a key part of it. I use UAD-2 FIrewire (not Apollo), so I definitely am concerned about this issue.
User avatar
Babz
 
Posts: 948
Joined: Sun Oct 17, 2004 10:01 pm
Primary DAW OS: Unspecified

Re: High Sierra, DP and UAD Pluggins

Postby James Steele » Fri Jan 12, 2018 6:18 pm

Makes me wonder if any of this applies to the UAD PCIe cards?
JamesSteele.com | Dean Guitars | Facebook | Google+ | Twitter

MacPro5,1 12-Core 3.33, 48GB RAM, macOS 10.12.6, ATI 5770, DP 9.5, MOTU HD192, 24I/O, UAD-2 Duo, Lucid GENx192, HV-3C, Red Type B, Dean guitars, Marshall amps, etc., etc.!
User avatar
James Steele
Site Administrator
 
Posts: 17010
Joined: Fri Oct 15, 2004 10:01 pm
Location: San Diego, CA - U.S.A.
Primary DAW OS: MacOS

Re: High Sierra, DP and UAD Pluggins

Postby dix » Fri Jan 12, 2018 6:26 pm

Makes me wonder if any of this applies to the UAD PCIe cards?
Ah. As opposed to Apollos etc. That hadn't occurred to me. Jim's okay with his card, so maybe not.
2009 4,1 > 5,1 MacPro 12-core 3.33 ghz , 10.11.6, 24GB RAM, ATI Radeon 5770 (3-monitors), Evo 840/850 SSDs, NewerTech eSATA/USB3 PCIe Host Adapter, DP (latest version), 2408mk3, Apogee Ensemble, UAD-2 Quad, VEP6 ::: 15-inch MBP (2015) 10.12.5, 16GB RAM ::: prayforrain.com
User avatar
dix
 
Posts: 1784
Joined: Fri Oct 15, 2004 10:01 pm
Location: San Francisco
Primary DAW OS: MacOS

Re: High Sierra, DP and UAD Pluggins

Postby James Steele » Fri Jan 12, 2018 8:53 pm

dix wrote:
Makes me wonder if any of this applies to the UAD PCIe cards?
Ah. As opposed to Apollos etc. That hadn't occurred to me. Jim's okay with his card, so maybe not.


Right... so perhaps this is with external UAD boxes connected via FW or TB only? I don't have High Sierra on my Mac, and don't really intend to install it so I can't corroborate. I know the PCIe cards are slowly being phased out so not much help there, but might be useful info to know this isn't affecting the UAD PCIe cards.
JamesSteele.com | Dean Guitars | Facebook | Google+ | Twitter

MacPro5,1 12-Core 3.33, 48GB RAM, macOS 10.12.6, ATI 5770, DP 9.5, MOTU HD192, 24I/O, UAD-2 Duo, Lucid GENx192, HV-3C, Red Type B, Dean guitars, Marshall amps, etc., etc.!
User avatar
James Steele
Site Administrator
 
Posts: 17010
Joined: Fri Oct 15, 2004 10:01 pm
Location: San Diego, CA - U.S.A.
Primary DAW OS: MacOS

Re: High Sierra, DP and UAD Pluggins

Postby Gravity Jim » Sat Jan 13, 2018 1:46 pm

Yeah, I run a pair of PCIe cards and have not had a problem with any version of OSX 10.11, 10.12 or 10.13.

You guys might be onto something with this Firewire thing.
Jim Bordner
http://www.gravitymusic.com
MacPro 5,1 (3.33Ghz 12-core), 32g RAM, OS X 10.13.3 Beta • MOTU 896mk3 • MOTU DP 9.5.1 • Logic Pro X 10.2.5 • Waves Diamond, UAD-2, Slate Digital, Komplete, Omnisphere 2, LASS, CineSamples, Chipsounds, V Collection 5, Korg Legacy • Roland & Yamaha hardware • Fender, Gibson, Godin, Danelectro, Line 6, Warmoth, Hofner and Cedar Creek guitars, Fuchs ODS amp
User avatar
Gravity Jim
 
Posts: 1830
Joined: Wed Apr 30, 2008 2:55 am
Location: Santa Rosa, CA
Primary DAW OS: MacOS

Re: High Sierra, DP and UAD Pluggins

Postby IO » Mon Jan 15, 2018 10:27 am

Funny thing i fired up my system yesterday and was able to use my UAD plugins in DP. I thought to my self how is this possible? I closed DP and when i went to reopen it i got the error again so really strange behavior and not constant it seems.

I would guess it is with eternal boxes only, I can't use my UAD-1 quad pci-e card anymore as i upgraded my machine to a trash can and only use UAD boxes via TB now that have the DSP builtin.
3Ghz 8core Trash Can 64GB RAM OSX 10.13.2 | UAD Apollo 8 Quad | UAD Apollo Twin MKII Solo | DP 9.51 | ProTools 12.8.3 | Studio One 3 | Logic Pro X | DSP Quattro | Waves | UAD
IO
 
Posts: 131
Joined: Mon Apr 17, 2006 1:33 pm
Location: cyberspace
Primary DAW OS: MacOS

Previous

Return to Digital Performer [MacOS]: Troubleshooting/Criticism

Who is online

Users browsing this forum: Baidu [Spider] and 3 guests


Who is online

In total there are 4 users online :: 1 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 151 on Tue Jan 28, 2014 1:07 pm

Users browsing this forum: Baidu [Spider] and 3 guests

Login Form